1. Which two file systems contain the kernel?
a. /
b. /etc
c. /var
d. /usr
Answer: a,d
2. What type of files are located in /usr?
a. User home directories
b. NFS configuration files
c. System configuration files
d. Common user executables
e. Standard system library files
Answer: e
3. What permisssions does a file created with umask 000 have?
a. 755
b. 777
c. 666
d. 644
Answer: c
4. How can you get online information for /etc/vfstab?
a. man vfstab
b. man -s4 vfstab
c. man vfstab(5)
d. man /etc/vfstab
Answer: a,b
5. Which of the following statements for Solaris 8 is correct?
a. C programming uses C shell
b. The default shell is Bourne shell
c. Korn shell is default for root
d. The Solaris 8 operating system has 3 shells by default.
Answer: b
6. How can you change directories from /export/home/user1 to /export/home/user2 by relative path?
a. mv /user2
b. cd ../user2
c. cd ../../user2
Answer: b
7. Which option of mount can be used so no large files can be mounted?
a. -nolargefile
b. -nolgfile
c. -o nolargefile
Answer: a
8. Which command is used to pass an option from reboot command to PROM level boot command?
a. reboot -- -r
b. boot -- -r
c. reboot -r
d. shutdown -- -r
Answer: a
9. Given the following:
./ ../ .tst dir1/ file1 file2 file3 file4
How can you copy .tst to dir1?
a. cp * dir1
b. cp .* dir1
c. cp. *.* dir1
d. cp .tst dir1/
Answer: b,d
10. After rebooting the system without any intervention, the system is waiting at the OK prompt. What is the current run level?
a. 0
b. 1
c. 2
d. 3
e. 4
f. 5
g. 6
h. S or s
Answer: a
11. You want to run an NFS client environment but not an NFS server environment. Which run level you should choose?
a. 0
b. 1
c. 2
d. 3
e. 4
f. 5
g. 6
h. S or s
Answer: c
Run-level 2 permits NFS client activities, but not NFS server activities.
12. How do you use ufsdump command to create and verify an incremental level 5 backup of /dev/rdsk/c0t1d0s4?
a. ufsdump 0f /dev/rmt/0
b. ufsdump 5f /dev/rmt/0
c. ufsdump 5vf /dev/rmt/0
d. ufsdump 5xvf /dev/rmt/0
Answer: c
13. How many characters must be different from the previous password set?
a. 0
b. 1
c. 2
d. 3
Answer: d
14. How can you list all the files and directories with their type?
a. ls -al
b. ls -a
c. ls -f
d. ls -F
Answer: d
15. List all files and directories that start with "abc" and end in "1".
a. ls [a-c+1]
b. ls [abc+1]
c. ls [abc]*1
d. ls [abc]+1
Answer: c
16. How do you use tar command to see a file's contents in a tape drive?
a. tar -tf /dev/rmt/0
b. tar -tfv /dev/rmt/0
c. tar -tv /dev/rmt/0
d. tar -list /dev/rmt/0
Answer: b
17. What command is similar in syntax to tar and it can be used to compresses a file?
a. car
b. jar
c. dar
d. far
Answer: b
18. What command will create a sustainable device alias in Boot PROM?
a. nvalias
b. devalias
c. nvdevalias
d. alias
Answer: a
19. What command do you use to show the current run level?
a. runlevel
b. who -u
c. who -r
d. who -H
Answer: c
20. A power outage is schedule. Which command sequences are valid ways to shutdown so the system will not be damaged?
a. init 0
b. init 1
c. init 5
d. shutdown -i 0
e. shutdown -i 3
Answer: a,c,d
21. Which file would you check to determine whether a file system is mounted with the UFS logging option enabled?
a. /etc/files/vfstab
b. /etc/vfstab
c. /etc/dfs/sharetab
d. /etc/mnttab
Answer: b
22. The start-script "S88sendmail" will execute the functionality of "/etc/init.d/sendmail start:. What does the number 88 indicate?
a. The process ID (PID) of sendmail will be 88.
b. The sendmail process will be the 88th process started.
c. The script will be executed after scripts in the start directory with lower numbers have been executed.
d. 88 MB of RAM will be allocated to this process.
Answer: c
23. Which software install cluster configuration is not valid for the Intel platform?
a. Core
b. End User
c. Entire Distribution
d. Developer
e. Entire Distribution + OEM
Answer: e
The Entire Distribution + OEM selection includes SPARC hardware proprietary drivers in addition to the total software distribution, therefore, this selection is invalid. Intel systems do not utilize SPARC hardware or SPARC hardware drivers, such as the Quad ethernet adapter.
24. What command is utilized to install a patch?
a. instpatch
b. patchadd
c. addpatch
d. pkginst
Answer: b
25. What four vi commands will change you to insert mode?
a. a
b. A
c. i
d. x
e. I
f. d
Answer: a,b,c,e
26. What vi command will find all instances of "Solaris" and replace them with "Solaris Operating Environment"?
a. s/Solaris/Solaris Operating Environment/g
b. %s/Solaris/Solaris Operating Environment/g
c. %s/Solaris/Solaris Operating Environment/
d. %s/Solaris/Solaris Operating Environment/all
Answer: b
Answer c will replace the first instance only and then stop. Answers a and d are formatted incorrectly.
27. How do you use chmod to change the SGID bit?
a. chmod 544
b. chmod 644
c. chmod g-s
d. chmod +s
Answer: c
28. Where is the path_to_inst file stored (directory)?
a. /dev
b. /etc
c. /usr/etc
d. /
Answer: b
29. What kind of information is stored in /export/home?
a. user information
b. configuration files
c. system binaries
d. system libraries
Answer: a
30. Which table keeps track of mounted devices in real-time?
a. /etc/mnttab
b. /etc/vfstab
c. /etc/dfs/sharetab
d. /etc/mounted
Answer: a
31. What command works by attempting to load every system driver and attach to all device instances?
a. devadm
b. fsadm
c. devfsadm
d. prtconf
Answer: c
32. When you perform an "mget" in ftp, what option can you enable to remove prompting?
a. hash
b. prompt
c. glob
d. verbose
Answer: b
33. In Bourne shell, when a user logs in, what is the order of initialization files executed?
a. /etc/login then $HOME/.login
b. /etc/.login then $HOME/.login
c. /etc/profile then $HOME/.profile
d. /etc/environment then $HOME/.profile
Answer: c
34. In Korn shell, when a user logs in, what is the order of initialization files executed?
a. /etc/profile then $HOME/.kshrc
b. /etc/profile then $HOME/.profile then $HOME/.kshrc
c. /etc/profile then $HOME/.profile then $HOME/.login
d. /etc/profile then $HOME/.login
Answer: b
35. In C shell, when a user logs in, what is the order of initialization files executed?
a. /etc/.login then $HOME/.profile
b. /etc/.login then $HOME/.login then $HOME/.profile
c. /etc/.login then $HOME/.cshrc then $HOME/.login
d. /etc/.login then $HOME/.login
Answer: c
36. What vi command do you use to copy 3 lines of text and place them ABOVE the cursor?
a. y3P
b. 3yyP
c. yyyP
d. 3yP
Answer: b
37. What option works with mount, fsck, useradd, usermod, groupmod, groupadd?
a. -x
b. -y
c. -o
d. -1
Answer: c
38. Which of the following commands use option -o?
a. useradd
b. usermod
c. userdel
d. groupadd
e. groupmod
f. groupdel
Answer: a,b,d,e
39. What command do you use to create an Access Control List (ACL) for a file?
a. setfacl -s
b. setfacl -m
c. aclset -s
d. aclset -m
Answer: a
The command "setfacl -m" is used to modify existing ACLs.
40. What command will mount a High Sierra file system?
a. mount -F cdfs -o ro /dev/rdsk/c0t0d0s1 /cdrom/cdrom0
b. mount -f -o ro /dev/rdsk/c0t0d0s1 /cdrom/cdrom0
c. mount -f hsfs -o ro /dev/rdsk/c0t0d0s1 /cdrom/cdrom0
d. mount -F hsfs -o ro /dev/rdsk/c0t0d0s1 /cdrom/cdrom0
Answer: d
41. What utilities will display information for all active processes on the system?
a. ps
b. prstat
c. prtconf
d. sdtprocess
e. dmesg
Answer: a,b,d
42. You issue the command "pkill dtmail". What is default signal that kill command sends to "dtmail"?
a. SIGKILL
b. SIGINT
c. SIGHUP
d. SIGTERM
Answer: d
43. How is cpio utilized?
a. copies and extracts files from a file archive or tape device
b. measures and reports system disk performance data
c. measures and reports system network performance data
d. acts as a sniffer, showing every packet visible on the network
Answer: a
44. How do you back up the files which are modified 7 days ago with cpio command?
a. cpio -mod -7 -ocvdumC > /dev/rmt/0
b. find / -mtime 7 -print -mount -depth | cpio -ocvdumC > /dev/rmt/0
c. cpio -i7 -ocvdumC > /dev/rmt/0
d. find / -mtime 7 -print -mount -depth | cpio > /dev/rmt/0
Answer: b
45. True or false: tar compresses files?
a. True
b. False
Answer: b
The command tar archives files into one tar file, but does not compress them.
46. Which two programs are used to compress files?
a. jar
b. compress
c. tar
d. cpio
Answer: a,b
47. Which sub-command in the format menu is used to save the partition table to disk?
a. verify
b. label
c. print
d. saveall
Answer: b
48. Which directory contains the run control scripts?
a. /etc/init.d
b. /etc/rc
c. /etc/runctl
d. /etc/init/d
Answer: a
49. What does enabling the hash option in ftp do?
a. indicates size of file being transferred
b. indicates progress of file bring transferred
c. stops prompting for multiple file gets or puts
d. stops the file transfer in progress
Answer: b
The hash option causes a hash symbol (#) to be printed for every X number of bytes transferred or received.
50. What file can alter the use of the cancel command on the keyboard?
a. /etc/system
b. /etc/kbd
c. /etc/default/system
d. /etc/default/kbd
Answer: d
51. Which 4 vi commands will change vi to last line mode?
a. :, ?, /, !
b. :, ?, g, s
c. :, ?, G, S
d. E, ?, /, !
Answer: a
52. Which command is used to remote copy files to a foreign host?
a. ftp
b. rsh
c. rexec
d. rcp
Answer: d
53. What permission will a file created with umask 022 have?
a. 666
b. 644
c. 755
d. 777
Answer: b
54. What file defines the default run level?
a. /etc/default/runlevel
b. /etc/runlevel
c. /etc/inittab
d. /etc/system
Answer: c
55. What file system type is used to access PC formatted floppies?
a. dos
b. dosfs
c. fat
d. pcfs
Answer: d
56. What command is used to limit damage after the system is forced down?
a. repair
b. reset
c. sync
d. fixall
Answer: c
57. What command is used to determine whether a package has been successfully installed?
a. pkgchk -v
b. pkginfo -p
c. chkpkg -v
d. pkginst -v
Answer: a
58. What command will create a device file in the /devices dir and a symbolic link in the /dev dir when it is used?
a. devfsadm
b. lsdev
c. fsadm
d. prtconf
Answer: a
59. What is the purpose of the /var/run directory?
a. It is the repository for nonsystem temporary files that are not needed across system reboots
b. This file system contains files that are specific to the architecture of the system, such as SPARC executables
c. This file system is mounted and used by the system specifically for maintaining a list of active processes
d. It is the repository for temporary system files that are not needed across system reboots
Answer: d
A new tmpfs-mounted file system, /var/run, is the repository for temporary system files that are not needed across system reboots in this Solaris release and future releases. The /tmp directory continues to be repository for nonsystem temporary files. Because /var/run is mounted as a memory-based file system rather than a disk-based file system, updates to this directory do not cause unnecessary disk traffic that would interfere with systems running power management software. The /var/run directory requires no administration. You might notice that it is not unmounted with the umount -a or the umountall command. For security reasons, /var/run is owned by root.
|